DrupalCamp Краснодар 2017

16 декабря 2017 в городе Краснодаре пройдет DrupalCamp.
Регистрация, Доклады.

Проблема с psy/psysh при обновление Drush 8

При выполнение команды

composer global require drush/drush:dev-master

получил ошибку

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for drush/drush dev-master -> satisfiable by drush/drush[dev-master].
    - Conclusion: remove psy/psysh v0.5.2
    - Conclusion: don't install psy/psysh v0.5.2
    - drush/drush dev-master requires psy/psysh ~0.6 -> satisfiable by psy/psysh[v0.6.0, v0.6.1].
    - Can only install one of: psy/psysh[v0.6.0, v0.5.2].
    - Can only install one of: psy/psysh[v0.6.1, v0.5.2].
    - Installation request for psy/psysh == 0.5.2.0 -> satisfiable by psy/psysh[v0.5.2].

Чтобы вылечить выполнил

composer global require psy/psysh:~0.6

А после опять

composer global require drush/drush:dev-master
Теги: